Icedove 3.1.9 et Lightning / iceowl-extension

De gros soucis en ce moment sous Debian Sid 64 bits avec la dernière version 3.1.9 de Icedove (le clone de Thunderbird) et l’extension calendrier Lightning. Le paquet iceowl-extension 1.0~b2-5 qui apporte la fonctionnalité calendrier fait misérablement planter Icedove avec tout un tas de messages de ce genre dans .xsession-errors :

Error: [Exception... "'[JavaScript Error: "too much recursion" {file: "file:///usr/lib/icedove/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js" line: 526}]' when calling method: [calIOperationListener::onOperationComplete]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///usr/lib/icedove/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calProviderUtils.jsm :: cPB_notifyOperationComplete :: line 658"  data: yes]

J’ai résolu le problème en désinstallant les paquets coupables et en téléchargeant les « Nightly builds » qui vont bien, toute la difficulté étant de trouver lesquels vont bien, dans mon cas c’était .

aptitude purge iceowl-extension calendar-google-provider
wget http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-1.9.2/linux-xpi/lightning.xpi
wget http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-comm-1.9.2/linux-xpi/gdata-provider.xpi

Il ne reste qu’à les installer avec le gestionnaire d’extensions Icedove.

Lien

Calendar weblog

VN:F [1.9.22_1171]
Rating: 0.0/5 (0 votes cast)

Une réaction sur “Icedove 3.1.9 et Lightning / iceowl-extension”

  1. r0b1n

    Et pour le retrouver en Français :
    https://debian-facile.org/viewtopic.php?id=8924

    VA:F [1.9.22_1171]
    Rating: 0 (from 0 votes)

Laisser une réponse